トレスタをご利用する際によくあるご質問や、いただいたお問い合わせ内容などをまとめています。
このほかの質問については、サポートサイト内お問い合わせフォームよりお気軽にお問い合わせください。

【Q.1】
・新規エントリーのアラートが出たのに注文が通らなかった。
・アラートエラーの原因を知りたい。

ほとんどの新規エントリーの失敗はアラート履歴でエラーメッセージとして確認ができます。
アラートメッセージの一覧は、アラート履歴エラーコード一覧をご覧ください。

【Q.2】
・戦略に設定した投資金ギリギリまで銘柄を買い付けなかった。
・銘柄にエントリーしたが、想定よりも株数が少なかった。

トレスタの注文方法は「成行注文」であるため、その日のストップ高価格で買えるだけの株数を注文します。各証券会社では万全を持すという事で、「成行注文では、注文株数に対しその日のストップ高で買えるだけ資金がないといけない」と言うルールとなっています。

【例】前日終値1,200円の銘柄を100万円の投資金で買い付ける場合。

「前日終値が1,200円」の銘柄の「制限値幅は300円」のため、ストップ高株価は「1,500円」
【計算式】投資金1,000,000円 ÷ 1,500円 = 666.66 ⇒ 端数切捨ての為600株注文

【値幅制限一覧】

※臨時に制限値幅を変更し、制限値幅を拡大することがあります。

【Q.3】
・エントリー条件を満たしても売買を行っていない。
・TradingViewで売買アラートが出たのに売買を行わなかった。

主な原因と確認方法、対策をまとめましたので、下記の原因とあった対処を試みてください。

<原因>
TradingViewのアラートが遅延している。

<確認方法>
TradingViewのアラート履歴を確認し、アラートが見当たらなければ遅延の可能性大。

<対処法>
1分程度待つ。ほとんどの場合は数秒~1分でアラート履歴が更新されます。


<原因>
TradingViewのアラートがサーバーで配信ロストしている。

<確認方法>
TradingViewのアラート履歴にアラートがあるにも関わらずトレスタでは売買されず、トレスタのアラートエラーもない。

<対処法>
①ポジションを持っている場合はトレスタの決済ボタンで決済する。 アラート履歴があり、トレスタに反応がない場合は、TradingViewのWebhook配信時にサーバ間での配信ロストが疑われます。
この場合は再配信がないため、手動で決済、またはトレスタのトレード条件での決済を行ってください。
②TradingViewのエントリーの株数を増やし、決済の株数を複数回に分ける。トレスタはTradingViewで1エントリーに何株買い付ける設定を行っても、1回のエントリーアラートで「新規買い・売り」という判定しか行いません。それを利用し、「エントリーでは200株設定、決済は1秒ごとに100株づつ分ける」 などのスクリプトを組むと、最初の決済アラートがロスしても1秒後のアラートで決済を行います。
すでに決済済みのポジションの決済アラートはトレスタでは認識されないため、 アラートロスの回避対策となります。
(※バックテストがずれるので、バックテストの場合は100株づつになるパラメータを組んでおくとよいでしょう。)


<原因>
TradingView自体がサーバーエラー等で止まっている。

<確認方法>
TradingViewのチャートを開いて動いているかどうかを確認する。
チャートが動いていなければテクニカル分析もできずストラテジーが反応しない。

<対処法>
①ポジションを持っている場合はトレスタの決済ボタンで決済する。
②チャートが動き出せばチャート分析に従い売り買いを行うので、起動するまで待つ。

【Q.4】
・「不正なフォーマットのため、アラートを無視しました」というエラーが出た。

ストラテジーのコードの記入ミスが考えられます。
サンプルコードには、以下のように記載がございます。


///////////////////////////////////////////////////////////////
//
//【トレスタ連携情報】トレスタとの連携方法
//
///////////////////////////////////////////////////////////////
//
//トレスタのメニュー「会員情報」の「ストラテジー名」に記載された
//会員コードの[ ]内に記載された半角英数字を入力できるパラメータ「i_strategy_code」を追加
//
///////////////////////////////////////////////////////////////
i_strategy_code=input(“”,title=”ストラテジーコード”)
///////////////////////////////////////////////////////////////
//
//【トレスタ連携情報】新規・返済、方向の指定方法
//
///////////////////////////////////////////////////////////////

//
//・新規買いの場合は、commentに”[任意の文字列]:新規買い”を指定
//・返済売りの場合は、commentに”[任意の文字列]:返済売り”を指定
//
//・新規売りの場合は、commentに”[任意の文字列]:新規売り”を指定
//・返済買いの場合は、commentに”[任意の文字列]:返済買い”を指定
//
//「返済売り」は買いポジションに対する返済、「返済買い」は売りポジションに対する返済
//
//このテストストラテジーでは、下記の「ああああ」にご自身で考えた
//任意の売買名称を入力してください。
//
//また、エントリー、決済の発注の際は「comment=」の他に必ず「alert_message=i_strategy_code」を付け加えてください。
//
///////////////////////////////////////////////////////////////


・TradingViewのストラテジーを株価チャートに挿入する際に、ご自身のストラテジーコードが入力されているか。
・新規・返済、方向の指定方法が合っているか。(トレスタでは売買時のcommentに「:新規買い」「:新規売り」「:返済買い」「:返済売り」の4種類の文字列を組み込むことで、この文字列をもとに売り買いを発注します。)

上記の点を確認してもエラーが出てしまう方は、株式会社ナレッジクリエイションまでお気軽にお問い合わせください。
お問い合わせはこちら。

【Q.5】
・「発注を行いませんでした(立花証券e支店とのセッションが切断されています)」というエラーが出た。

・「発注を行いませんでした(立花証券e支店口座と連携されていません)」というエラーが出た。

上記のエラーは、トレスタと証券口座が連携されていない場合に表示されるエラーとなります。

■セッションの切断で考えられる原因
→他サービスと立花証券を連携した、第二暗証番号を変更した、金商法上の未読事項が原因と考えられますので、確認してみましょう。

■その他の原因
→トレスタと証券会社が正しく連携されているか確認しましょう。

①トレスタにログインし、右のメニューにある『会員情報』から「立花証券e支店口座」を確認する。
②下記のように「ユーザID」や「暗証番号」が入力されているか確認する。

③口座情報が入力されていない場合は、『口座情報を入力』のボタンをクリックし、「立花証券e支店ユーザID」と「立花証券e支店暗証番号」を入力して、口座情報を保存する。